Office Online Server and Office Web Apps Server Fails to present when installed in non-default path

By | July 27, 2017

Another one I’ve been scratching my head for days on and finally found a fix.
I cant take all the credit for this. One of my co-workers Chris helped find the solution along with some pointers from the TechNet forums over here

Also turns out the sexy beast that is Ken Lasko ran into a similar issue a few years back. However in that case running Get-OfficeWebAppsFarm would fail.

The Issue

When attempting to share a Powerpoint slide deck via a freshly installed Office Web Apps or Office Online Server, the file uploads and presents a loading screen, but times out with an error asking you to try again.

We weren’t getting anywhere fast with this one. we ran through all the usual checks.

  • Discovery URL works, Check
  • SSL certificate assigned and working, Check
  • Skype4B frontends were not logging Event ID 41033 (Office Web Apps Discovery Failure), Check
  • Skype4B Frontends were logging Event ID 41034 (Conferencing Service Discovered Office Web Apps Server), Check
  • Get-OfficeWebAppsFarm output looked fine, Check
  • Both our LoadBalanced and our Standalone pools were doing this

 

We jumped into Fiddler and was met with half open connections or temporally unavailable messages and nothing usfull, IIS logs weren’t much help either. The only interesting things we could see were

Running Get-OfficeWebAppsMachine showed the host as “Unhealthy” but no obvious reasons in the event log.

We could see that all the relevant services Sandbox.exe was starting a lot. with Event ID 6547 logged over and over showing a process had exited and was being restarted.

The events would log like this, All Event ID 6547 under the “Microsoft Office Web Apps” node.

The following logs can apply to the sandbox for any of the following services Proofing, OneNoteMerge, RichEditMathConversion or Imaging

  • About to dispose ConsoleOutputWriter for Proofing
  • Path to console service D:\Program Files\Microsoft Office Web Apps\Proofing\SandboxHost.exe
  • Starting process for agent Proofing
  • Starting service with command line: D:\Program Files\Microsoft Office Web Apps\Proofing\SandboxHost.exe
  • Service Proofing has exited, sleeping for 10 seconds before restarting it

The Fix

The fix was simple. Office Online Server doesn’t like being installed on a non-default drive.
We had installed it in D:\Program Files\Microsoft Office Web Apps\ as the customer wanted their applications on a separate drive to the Operating System

We reinstalled OOS on C: and everything came good.

As always, Hope this helps

 

 

5 thoughts on “Office Online Server and Office Web Apps Server Fails to present when installed in non-default path

    1. James ArberJames Arber Post author

      Thanks Ken. Hoping throwing the event log id and messages in here might help someone with google/bing-fu

      Reply
      1. James ArberJames Arber Post author

        Looking into it, same but different issue. Post updated with a nice link for you Ken

        Reply
  1. 58sniper

    There is a fix for this that involves copying some files. I’m drawing a blank as to where I read that. I’ll look around.

    Reply

Leave a Reply